Configuring RIP Interface Parameters

When it comes to configuring RIP, there are serveral interface parameters that can be configured to fine tune the operation of RIP. This lab will discuss and demonstrate the configuration and verification of RIP interface parameters.

Real World Application & Core Knowledge

So what happens if you have a network that has both RIP version 1 and version 2? This could be a problem when one company buys another company in which company A uses RIPv1 and Company B uses RIPv1.

There are two options under interface configuration mode that will allow you to set the version(s) in which the router will send and/or receive. This gives you the ability to have two different RIP version environments and give you the ability to migrate the RIPv1 network to the RIPv2 standard. By default when you use RIPv2, the RIP process is set to only send/receive RIPv2 updates. This can be changed to include RIPv1 if there is a need for it.

To enable the transmission of RIPv1 and RIPv2 updates you’ll execute the ip rip send version 1 2 on a per interface basis. To enable RIP to process RIPv1 and RIPv2 updates, the command you’ll need to execute on a per interface basis is ip rip receive version 1 2

The next concept this lab will discuss is how to configure RIPv2 to send its updates using a broadcast destination address and not to the multicast destination address of 224.0.0.9:520. This configuration is sometimes required in environments where multicast is prohibited. In Lab 7-6 you will learn how to configure static neighbors which sends the updates via unicast.

Enabling RIPv2 to send broadcast updates is done on a per interface basis using the ip rip v2-broadcast command in interface configuration mode.

This lab will continue to build upon the same logical topology used in the previous Lab 7-4 as shown below;

In this lab you will configure R2 and R3 to send RIPv1 and RIPv2 updates between each other on their Frame Relay point-to-point interface. You will also configure R1 to send RIPv2 updates as broadcast to R2 via the point-to-point interface.

Familiarize yourself with the following new command(s);

Command Description
ip rip send version # This command is executed in interface configuration mode and specifies which version(s) of RIP updates can be sent via that interface.
ip rip receive version # This command is executed in interface configuration mode and specifies which version(s) of RIP updates can be received and processed via that interface.
ip rip v2-broadcast This command is executed in interface configuration mode and specifies that RIPv2 should send updates out that specific interface using broadcast and not multicast.

Lab Prerequisites

  • If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start devices; R1, R2 and R3.
  • Establish a console session with devices R1, R2 and R3 than load the initial configurations provided below by copying the config from the textbox and pasting it into the respected routers console
!##################################################
!# Free CCNA Workbook Lab 7-5 R1 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R1
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.70.10.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.122 point-to-point
description ### FRAME RELAY LINK TO R2 ###
ip address 10.70.12.1 255.255.255.252
frame-relay interface-dlci 122 
!
interface Serial0/0
no shut
!
interface Serial0/1
description ### PPP Link TO R2 ###
ip address 10.70.21.1 255.255.255.252
encapsulation ppp
serial restart-delay 0
clock rate 128000
no shut
!
exit
!
router rip
version 2
network 10.0.0.0
timers basic 30 40 10 60
!
end
!##################################################
!# Free CCNA Workbook Lab 7-5 R2 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R2
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.70.20.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.221 point-to-point
description ### FRAME RELAY LINK TO R1 ###
ip address 10.70.12.2 255.255.255.252
frame-relay interface-dlci 221
ip rip triggered
!
interface Serial0/0.223 point-to-point
description ### FRAME RELAY LINK TO R3 ###
ip address 10.70.23.1 255.255.255.252
frame-relay interface-dlci 223
!
interface Serial0/0
no shut
exit
!
interface Serial0/1
description ### PPP LINK TO R1 ###
ip address 10.70.21.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
clock rate 128000
no shut
exit
!
router rip
version 2
network 10.0.0.0
timers basic 30 40 10 60
!
end
!##################################################
!# Free CCNA Workbook Lab 7-5 R3 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R3
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.70.30.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.322 point-to-point
description ### FRAME RELAY LINK TO R2 ###
ip address 10.70.23.2 255.255.255.252
frame-relay interface-dlci 322
ip rip advertise 10
ip rip triggered
!
interface Serial0/0
no shut
exit
!
router rip
version 2
network 10.0.0.0
timers basic 30 40 10 60
!
end

Lab Objectives

  • Configure R2 to send and receive RIP Version 1 and 2 updates on the point-to-point link towards R3. Verify your configuration.
  • Configure R2 to send and receive RIP Version 1 and 2 updates on the point-to-point link towards R2. Verify your configuration.
  • Configure R1’s point-to-point interface towards R2 to send RIPv2 updates as broadcast. Verify your configuration using the debug ip rip events

Lab Instruction

Objective 1. – Configure R2 to send and receive RIP Version 1 and 2 updates on the point-to-point link towards R3. Verify your configuration.

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface Serial0/0.223
R2(config-subif)#ip rip send version 1 2
R2(config-subif)#ip rip receive version 1 2
R2(config-subif)#end
R2#
R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 24 seconds
  Invalid after 40 seconds, hold down 0, flushed after 60
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0.221         2     2                                    
    Serial0/0.223         1 2   1 2        Yes                       
    Serial0/1             2     2                                    
    Loopback0             2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.70.12.1            120      00:00:28
    10.70.23.2            120      00:31:10
    10.70.21.1            120      00:00:00
  Distance: (default is 120)

R2#

Objective 2. – Configure R2 to send and receive RIP Version 1 and 2 updates on the point-to-point link towards R2. Verify your configuration.

R3>enable
R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface Serial0/0.322
R3(config-subif)#ip rip send version 1 2
R3(config-subif)#ip rip receive version 1 2
R3(config-subif)#end
R3#
R3#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 8 seconds
  Invalid after 40 seconds, hold down 0, flushed after 60
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0.322         1 2   1 2        Yes                       
    Loopback0             2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.70.23.1            120      00:35:30
  Distance: (default is 120)

R3#

Objective 3. – Configure R1’s point-to-point interface towards R2 to send RIPv2 updates as broadcast. Verify your configuration using the debug ip rip events

R1>enable
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface Serial0/1
R1(config-subif)#ip rip v2-broadcast
R1(config-subif)#end
R1#

To verify that RIP is indeed sending RIPv2 updates via broadcast you can use the debug ip rip events command as shown below;

R1#debug ip rip events
R1#
RIP: sending v2 update to 255.255.255.255 via Serial0/1 (10.70.21.1)
RIP: Update contains 3 routes
RIP: Update queued
RIP: Update sent via Serial0/1
R1#

As you can see RIP reported that it was sending a v2 update to 255.255.255.255 (Broadcast) via Serial0/1. This confirms that RIPv2 is indeed sending broadcast updates to R2 via the point-to-point frame-relay link.

Leave a comment