Configuring RIP Timers

The default timers on RIP can be tuned to meet the requirements of your network. This lab will discuss and demonstrate the configuration and verification of RIP Timers.

Real World Application & Core Knowledge

In today’s networks the convergence time for RIP just isn’t fast enough. With the default timers, RIP convergence can take longer than three minutes which is just completely unacceptable in today’s networks.

If you take a look back to lab Configuring Routing Information Protocol (RIP) it discusses the different types of timers and what they do. In this lab you’ll learn how to modify the timers to decrease convergence time.

The timers are configured in rip router configuration mode as a global setting however the update timer can be configured on a per interface basis.

To set the timers you’ll use the timers basic update# invalid# holddown# flush#. Each # is represented as a value in seconds. i.e; timers basic 30 40 10 60

To set the update timers manually per interface you’ll use the ip rip advertise # where as # is the interval in seconds at which updates are sent.

This lab will use the same logical topology as used in Lab 7-2 which is shown below;

In this lab you will configure the timers on all routers to 30 second updates, 40 second invalid, 10 second hold down and 60 second flush and manually set R3 to send updates to R2 every 10 seconds over interface Serial0/0.322

Familiarize yourself with the following new command(s);

Command Description
timers basic 30 40 10 60 This command is executed in rip router configuration mode to globally set the update, invalid, hold down and flush timers of the RIP routing process.
ip rip advertise # This command is executed in interface configuration mode to specify the interval in seconds at which RIP updates are sent out the specific interface.

Lab Prerequisites

  • If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start devices; R1, R2 and R3.
  • Establish a console session with devices R1, R2 and R3 than load the initial configurations provided below by copying the config from the textbox and pasting it into the respected routers console.
!##################################################
!# Free CCNA Workbook Lab 7-3 R1 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R1
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.70.10.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.122 point-to-point
description ### FRAME RELAY LINK TO R2 ###
ip address 10.70.12.1 255.255.255.252
frame-relay interface-dlci 122 
!
interface Serial0/0
no shut
!
interface Serial0/1
description ### PPP Link TO R2 ###
ip address 10.70.21.1 255.255.255.252
encapsulation ppp
serial restart-delay 0
clock rate 128000
no shut
!
exit
!
router rip
version 2
network 10.0.0.0
exit
!
line con 0
logging sync
no exec-timeout
end
!##################################################
!# Free CCNA Workbook Lab 7-3 R2 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R2
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.70.20.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.221 point-to-point
description ### FRAME RELAY LINK TO R1 ###
ip address 10.70.12.2 255.255.255.252
frame-relay interface-dlci 221 
!
interface Serial0/0.223 point-to-point
description ### FRAME RELAY LINK TO R3 ###
ip address 10.70.23.1 255.255.255.252
frame-relay interface-dlci 223
!
interface Serial0/0
no shut
exit
!
interface Serial0/1
description ### PPP LINK TO R1 ###
ip address 10.70.21.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
clock rate 128000
no shut
exit
!
router rip
version 2
network 10.0.0.0
exit
!
line con 0
logging sync
no exec-timeout
!
end
!##################################################
!# Free CCNA Workbook Lab 7-3 R3 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R3
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.70.30.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.322 point-to-point
description ### FRAME RELAY LINK TO R2 ###
ip address 10.70.23.2 255.255.255.252
frame-relay interface-dlci 322
!
interface Serial0/0
no shut
exit
!
router rip
version 2
network 10.0.0.0
exit
!
line con 0
logging sync
no exec-timeout
end

Lab Objectives

  • Configure the RIP timers on R1, R2 and R3 to 30 second updates, 40 second invalid, 10 second hold and 60 second flush. Verify your configuring.
  • On R3 configure Serial0/0.322 to send updates every 10 seconds towards R2. Verify your configuration.

Lab Instruction

Objective 1. – Configure the RIP timers on R1, R2 and R3 to 30 second updates, 40 second invalid, 10 second hold and 60 second flush. Verify your configuring.

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#timers basic 30 40 10 60
R1(config-router)#end
R1#show ip protocols 
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 26 seconds
  Invalid after 40 seconds, hold down 10, flushed after 60
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0.122         2     2                                    
    Serial0/1             2     2                                    
    Loopback0             2     2                                    
    Loopback1             2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.70.12.2            120      00:00:05
    10.70.21.2            120      00:00:05
  Distance: (default is 120)

R1#
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router rip
R2(config-router)#timers basic 30 40 10 60
R2(config-router)#end
R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 16 seconds
  Invalid after 40 seconds, hold down 10, flushed after 60
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0.221         2     2                                    
    Serial0/0.223         2     2                                    
    Serial0/1             2     2                                    
    Loopback0             2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.70.12.1            120      00:00:15
    10.70.23.2            120      00:00:03
    10.70.21.1            120      00:00:06
  Distance: (default is 120)

R2#
R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router rip
R3(config-router)#timers basic 30 40 10 60
R3(config-router)#end
R3#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 22 seconds
  Invalid after 40 seconds, hold down 10, flushed after 60
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0.322         2     2                                    
    Loopback0             2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.70.23.1            120      00:00:21
  Distance: (default is 120)

R3#

Objective 2. – On R3 configure Serial0/0.322 to send updates every 10 seconds towards R2. Verify your configuration.

R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#interface Serial0/0.322
R3(config-subif)#ip rip advertise 10
R3(config-subif)#end

There are three ways to verify that the interface timer that you’ve configured is operating properly. The first method of verification is that you can run debug ip rip events on R2 to view how often the updates are coming from R3, they should be approximately 10 seconds apart give or take a few seconds.

The second method you can use to verify that the interface specific advertisement timer is operating correctly is using the show ip protocols command on R2 and you should see the last update received from 10.70.23.2 never go above 10 seconds.

And the last method of verification however is not documented in any Cisco documentation and the command is a hidden command that will not show up when using the ?. The command is called show ip rip timers This command is very vague and does not display any details at all however it does show the update intervals on a per interface basis. This command will show the time it the router will wait before it sends another update through an interface.

When you do show ip protocols under rip you’ll see the interfaces listed in order as shown below;

R3#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 6 seconds
  Invalid after 40 seconds, hold down 10, flushed after 60
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0.322         2     2                                   
    Loopback0             2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.70.23.1            120      00:00:11
  Distance: (default is 120)

R3#

You can see that Serial0/0.322 is listed first and Loopback0 is second. Now when you execute the show ip rip timers command in privileged mode you’ll see the following output;

R3#show ip rip timers
  RIP timers
    Expiration    Type
|           3.680  (parent)
  |           3.680  Ager interval
  |           7.172  (parent)
    |           7.172  Periodic update
    |          25.722  Periodic update
R3#

When you look at the output you’ll see two Periodic update timers, the first one being Serial0/0.322 which will send its next update in 7.172 seconds and Loopback0 which will send its next update in 25.722 seconds.

Note that the Ager interval is the “hold down” timer.

Leave a comment